Version actuelle
0.8.4.2
 

Forums

Un problème, une idée d'amélioration ?
C'est ici que ça se passe !

You are not logged in.

Announcement

Suivez l'actualité du développement de Hyla sur son blog : http://blog.hyla-project.org/
  • Index
  •  » Général
  •  » compatibilité avec php 5.3 pose probleme ...

#1 2011-02-04 11:36:49

doubleki
Membres
Registered: 2011-02-04
Posts: 3

compatibilité avec php 5.3 pose probleme ...

bonjour,

en effet je viens de découvrir votre outil qui me semble très bien, cependant j'essaie de l'utiliser en local en vue par la suite de le mettre sur un site chez un hébergeur, et je me rend compte qu'il n'est pas compatible avec php 5.3, sans même l'avoir installé puisque déjà sur la page d'install j'ai ça :

Deprecated: Assigning the return value of new by reference is deprecated in C:\xxxx\install.php on line 325
Deprecated: Assigning the return value of new by reference is deprecated in C:\xxxx\install.php on line 647
Deprecated: Assigning the return value of new by reference is deprecated in C:\xxxx\install.php on line 739
Deprecated: Assigning the return value of new by reference is deprecated in C:\xxxx\install.php on line 869


comment faire, je suppose que je ne suis pas le premier a vous le dire ?
avez vous une solution autre que de redescendre dans ma version php, car j'ai besoin en revanche sur des choses que j'ai codé moi-même de la version 5 de php ...

merci beaucoup,

Offline

 

#2 2011-02-04 14:28:28

hugo
Administrateur
Registered: 2007-04-10
Posts: 807

Re: compatibilité avec php 5.3 pose probleme ...

Bonjour,

Hyla est tout à fait compatible avec Php 5.3, ce que tu vois, c'est juste des avertissements concernant une pratique qui ne doit plus se fait avec la version 5.3, ça n'empêchera pas Hyla de fonctionner correctement, si tu ne veux voir ces averissements, tu peux les faire disparaitre en modifiant ton php.ini.

++

Offline

 

#3 2011-02-04 16:39:33

doubleki
Membres
Registered: 2011-02-04
Posts: 3

Re: compatibilité avec php 5.3 pose probleme ...

ok merci de cette reponse ...

Cela dit avez vous une suggestion de "customisation" car chez un hebergeur le php.ini n'est pas accessible ...
j'imagine donc qu'il faut que je mette un php.ini a la racine (du site ? du repertoire de hyla ?) mais avec une commande de quel type ... ( j'ai de bonne notions de php... mais je reste un amateur;-) )
merci de cette aide.
dk.

Last edited by doubleki (2011-02-04 16:41:37)

Offline

 

#4 2011-02-07 20:59:06

doubleki
Membres
Registered: 2011-02-04
Posts: 3

Re: compatibilité avec php 5.3 pose probleme ...

donc pas de suggestion ... apparemment ...
ben tant pis ça avait l'air pas mal je vais donc passer a autre chose ...


l'outil est top, les fonctionnalités bien vues, l'interface est moche (mais les gouts et les couleurs ;-) ) et pis l'interface on peut se refaire un theme.
peut être aurons nous la chance d'avoir une version mise a jour, avec un accès a la BDD en PDO et sans customisation a faire,
encore que ça ne me gêne pas de faire des ajustements, c'est même super de pouvoir en faire
mais une update j'ai pas le niveau donc pour l'instant je me tourne vers un autre outil,
car ça ne parait pas très propre de couper les messages d'erreurs signalant le coté obsolète du code.

dommage, parce que le concept est chouette ... et les fonctionnalités intéressantes,
j'attends donc la suite.

cordialement votre,

d.

Last edited by doubleki (2011-02-07 21:06:35)

Offline

 

#5 2011-02-08 00:42:49

hugo
Administrateur
Registered: 2007-04-10
Posts: 807

Re: compatibilité avec php 5.3 pose probleme ...

Salut,

Mettre un php.ini ce changerait rien, il faut que tu modifies celui utilisé par le serveur web, renseigne toi auprès de ton hébergeur pour savoir si il est possible de faire taire le serveur web, ce qui est d'ailleurs une bonne pratique en général...

je suis en ce moment en train de bosser sur une version de maintenance qui supprimera ces avertissements.

++

Offline

 
  • Index
  •  » Général
  •  » compatibilité avec php 5.3 pose probleme ...

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson